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Module Overview 

In this module we will be looking at how to describe a database and view desired information 
contained within for optimal use. 

Module Objectives: 

 Learn terminology for parts of a database 

 Learn how field names (headings) are used by Excel in databases 

 Learn how lists and tables are databases  

 Learn how to filter and sort only the information needed 

 Learn how to freeze a section of the database in the current view 
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1. Database Concepts 
1.1. Database 

A spreadsheet is a collection of rows and columns. In Microsoft Excel 2010 a 
spreadsheet can contain 16,384 columns and 1,048,576 rows of information. The 
columns are lettered A, B, C, etc., ending with XFD. The rows are numbered 1 through 
1048576.  

Every cell in the spreadsheet has an address created by combining the column letter 
with the row number. The cell C4 is the intersection of column C and row 4.  

 

 

A database is a collection of related information that is organized for a particular 
purpose. Examples of databases might include an address book, a store’s inventory, 
information about a collection (art, music, coins, baseball cards) or a club membership 
list.  

1.2. Records 

The various pieces of information that relate to one individual or one item are called a 
database record. A record consists of multiple fields. If the database is designed for use 
as an address book, the field names might be First Name, Last Name, Address, City, 
State and Zip. The data entered in each field is called an entry.  

Follow 
Me 

The Name Box 

1. Open a blank spreadsheet. 
2. Find the Name Box, above the column A header. 
3. Watch the name box as you click around the various cells in the sheet. See 

that the letter of the column and number of the row you’ve selected appear 
in the name box, combined as the cell name. 
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For example, in this database:  

Database Friends Addresses 

Record Barrow/Ed/319 N Washington/Hinsdale/IL/60521 

Field Name First Name 

Field or Entry Ed 

1.3. Field Names 

Excel only understands that you want to use it as a database because of certain 
patterns it sees as you enter data. The most important of these patterns is the creation 
of a header row.  

 

Look closely at the image above. How does Excel know that Street is a Field Name and 
not an Entry? How does Excel know that Hinsdale is an Entry and not a Field Name?  
You tell Excel by formatting the first row in a way which is significantly different from the 
rest of the entries. Here, Field Names are Bold and Red while Entries are Plain and 
Black.  

 

Follow 
Me 

Identify Field Names 

1. Open a the Baseball Roster spreadsheet 
2. Determine which cells contain the field names 
3. Format the field names: Font Arial Black 
4. Format the field names: Text Color Red 
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Also important is how you tell Excel what the boundaries of the database are. This is 
done by using empty cells. Excel first reads fields from left to right. When it encounters 
a completely empty column of cells it interprets that as the right edge of the database. 
Then it reads top to bottom. When it reaches a row of completely empty cells it 
interprets that as the bottom edge of the database. So you tell Excel about the size of 
the database by how you locate empty cells. 

1.4. Fields 

Before creating a database, determine the purpose served by the information. Then set 
the categories (Field Names) you will need in reports or that you want to use to sort or 
select specific records. Determining the scope focuses the information relevant to an 
individual or item in the database.  

Think of yourself for a moment. There is address information associated with your 
name. But there is also financial, physical, work history, and lots of other kinds of 
information associated with your name. If all of it is put into a single database, the 
database would quickly become unmanageable.  

Multi-dimensional databases are complicated in Excel. Setting boundaries makes Excel 
most effective. Useful categories depend on the database purpose. For some purposes 
it is enough to have a field name called Name. For other purposes you may want to 
have fields for First Name, Last Name, Title, etc. For example, if you wish to be able to 
use only the first name in the salutation of a letter, you would set up your database with 
separate first and last name fields. While it is possible to add Field Names after the fact, 
it is often very time consuming. A useful database reflects good planning.  

1.5. List 

If a database has only one column in it, Excel calls it a List. 
This is a one-dimensional database, topped with a field name 
(column header) and bottomed with an empty cell. Below is a 
list of members of a team. 

 

1.6. Table 

If a database has several columns, Excel calls it a Table. This 
is a two dimensional database, topped with a header row, bound on the right side by an 
empty column, bottomed by an empty row. Below is 
a table of team members and their positions.  
 
These terms are useful if you ever have to query 
Help. Querying “database” in Help yields results 

Follow 
Me 

Database planning 

1. Think about developing an employee directory for your place of work. 
2. What fields would be helpful to have in an employee directory? 
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about how Excel and Microsoft Access work together, rather than information on tables 
or lists.  

2. Organizing Data 
2.1. Sort 

The information in a database can be sorted and records can be selected that match 
certain criteria. To sort information in a spreadsheet, first select the range of cells you 
want to sort. Second, select the Sort & Filter button on the Home tab, (Editing group) or 

the Sort command on the Data tab (Sort & Filter group).  

 

Keep in mind, if you sort only one column without sorting the 
rest of the table, you will decouple that column from the 
others. Consider a name and address table like that shown 
earlier in the lesson. Sorting only column A results in 
decoupling last names from the other elements that make up 
the complete name 
and address – all of 
the information will 
become 

mismatched.  This error occurs so often, Excel 
will issue a warning before it executes the sort.  

 

 

Most likely you want to sort all the columns of information together. Accepting the 
default option to Expand the selection is probably what you want.  But Excel will only 
expand the selection to include columns which are touching (contiguous) and containing 
data.  If your table contains a column which is empty, Excel interprets that column as a 
boundary of the table and the expansion will not include data in columns on the far side 
of that empty column. To prevent this, cancel the sort, reconsider what your intent is, 
possibly delete the empty column(s) and reselect the data to be sorted.  

Follow 
Me 

Sort  

1. Open the Baseball Roster spreadsheet 
2. Select all of the names of the team members 
3. Click on Sort & Filter 
4. Select Sort A to Z 
5. Select Expand the selection to sort each player’s position with their name. 
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If you select a single cell in the 
table and then initiate the sort 
from the Data tab (Sort & Filter 
group), instead of the Sort 
Data/Filter button on the Home 
tab, Excel will highlight its 
interpretation of the table. It’s a 
quick visual check to see if 
Excel is about to sort what you 
really want it to.  

 

 

2.2. Custom Sort 

For expanded or specific Sorting options, select Custom Sort from the Sort/Filter drop 
down menu in the home tab (Editing group).  

If the table has column headers (Field Names) you can avoid sorting the titles with the 
other information by selecting the “My data has headers" check box. If the formatting of 
the header row is the same as the rest of the table then Excel will assume there is no 
header row and the default offered will be ho header row.  

The image below shows the Field Names Last Name and First Name, both to be sorted 
in ascending sequence.  

Multiple levels of sort are possible using Custom Sort. The first priority sort is at the top 
of the dialog box. The next sort is performed second, and so on. To add additional 
levels of sorting, click on the “Add level” button.  

 

If the sort shown here were executed, the table would be sorted first name within last 
name just as a phone book is sorted. If there were no column headers used, the levels 
of sort would be based on Column A and Column B instead of column headers.  

If the sort did not turn out as expected, remember you can always select the Edit Menu 
and Undo command to return the list to its original order.  
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2.3. Filter 

It may be useful to narrow a very large spreadsheet down to a smaller portion of the 
data without seeing all the data that is not of interest. In fact, there are two methods, 
filtering the data and splitting the window. A filter lets you see only a portion of the data 
based on selection criteria. You set the filter criteria from the Sort & Filter button under 
the Home tab (Editing group) or the Data tab (Sort & Filter group). 

 AutoFilter is a toggle switch, 
selected (on) or not selected (off).  

 

When AutoFilter is On, it puts a drop 
down menu at the top of every 
column in the database. If you click on a drop down arrow, all the different values in that 
column are shown. You can then select from that menu to display only the records 
containing a particular value or values.  

The images below 
show a database of 
movies with AutoFilter 
selected, and then the 
same movie database 
filtered for the Star 
“Lucille Ball.” Note that 
the row numbers where 
“Lucille Ball” is found 
are also shown.  

 

 

Follow 
Me 

Filter 

1. Open the Movies spreadsheet 
2. Click on Sort & Filter 
3. Select Filter.  Notice that dropdown arrows appear for each field name 
4. Click on the dropdown for “Genre”  
5. Uncheck Select All and 

Check Comedy 
6. Click OK 
7. Click on the dropdown 

for “Studio” 
8. Uncheck Select All and 

Check MGM 
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2.4. Count 

Excel performs some basic 
counting functions to provide 
some additional information 
which may be helpful if the user 
knows where to look.  

 
Excel counts the number of rows 
as you select them. As seen 
below, the number of rows 
selected is shown by the final row 
number. “10R” indicates that ten 

rows are selected.  The same functionality applies to columns. 
 
 
In the image below, some cells are selected.  In the status bar, Excel gives the average 
of all of the numerical values in the selected cells, the number of cells selected, and the 
sum of all of the values in the cells. Here, those are 115.18, 11, and 1267, respectively. 
 

 
 

Follow 
Me 

Clear Filters 

1. Click on the Genre dropdown 
2. Click on the dropdown for “Genre”  
3. Select Clear filter from Genre 
4. Click on the dropdown for “Studio” 
5. Select Clear filter from Studio 
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Also in the Status bar, on the left hand side next to the word “Ready”, you can see the 
results of your filters.  In this case, out of a total of 331 records in the Movie table, 26 
records met the criteria of Genre = Comedy and Studio = MGM. 
 

3. Freeze Panes 

Often when you are working many 
rows or columns deep in a 
spreadsheet you can no longer see 
the headers of columns and rows. It 
is helpful to “freeze” the row and 
column titles in their respective 
places and use them as a guide 
when you are entering data. Excel 
provides a command called Freeze 
Panes located on the View Tab 
(Window group).  

 

Horizontal and vertical solid lines appear in the spreadsheet to the top and left of 
whichever cell is currently selected. These lines are a visual clue that the titles will not 
scroll out of sight.  Now you try! 

  

Follow 
Me 

Count selection 

1. With the movies spreadsheet open 
2. Filter the spreadsheet by Comedy and MGM 
3. Select the names of the movies in column B that are from 1939 
4. Look to the status bar to see how many Comedy movies were made by 

MGM studios in 1939. (12!) 
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To remove the freeze, select the Freeze Panes button located on the View Tab, 
Window group and choose Unfreeze Panes from the dropdown menu.  

 

4. Exercises – Now You! 

- In the Movies database, Freeze the header row with the field names. 

- Use Sort and Filter as well as Count to determine: 

 Which Movie star made the most movies in 1940? 

 Who was the only actor in a Fantasy movie? 

 How many comedies did RKO make in 1939? 

 Were there more action movies made in 1939 or 1940? 

 How many films starred Ginger Rogers or Fred Astaire? 

  

  

Follow 
Me 

Freeze panes 

1. Open the Family Budget spreadsheet 
2. Click on the cell B4 
3. On the View tab, Select Freeze Panes dropdown 
4. From the menu, select Freeze Panes 
5. Note that a vertical line appears to the left and a horizontal line appears 

above. 
6. Try scrolling vertically and horizontally and see how the headers remain 

frozen. 


